Jump to content
mutafakaz

Запись в сетевую папку на Линукс

Recommended Posts

Подскажите, есть Rackstation, на нём создана сетевая папка в которую любой может записывать информацию.

Линукс, через smb, видит в астралинуксе монтируется сетевое место.

Но Линия - отказывается видеть эту сетевую папку.

Буду благодарен за помощь.

Share this post


Link to post
Share on other sites

Здравствуйте!
В Linux «Линия»  ничего не монтирует, она использует fstab.

Необходимо самостоятельно подключить  сетевой каталог по нужному протоколу и под нужным пользователем, а в «Линии» указать локальный путь (точку монтирования).  Попробуйте в fstab прописать:

//IP/share /mnt/share cifs username=line,password=line,rw,nolock,auto,vers=2.0,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0

 

//IP/share - адрес шары
/mnt/share - точка монтирования (рекомендуют использовать вместо каталога mnt каталог media)
cifs - один из способов (протокол) передачи данных по сети с одного устройства на другое
username= - имя пользователя для которого доступна сетевая папка
password= - пароль пользователя для которого доступна сетевая папка
rw - монтировать файловую систему для чтения и записи
nolock - не использовать блокировку, возможно, необходимо использование nobrl 
auto - файловая системы будет смонтирована автоматически при загрузке или после выполнения команды 'mount -a'.
vers=2.0 - версия SMB протокола
iocharset=utf8 - устанавливает, какую кодировку использовать при установке дисков или сетевых ресурсов
file_mode=0777 - устанавливаем права на файлы
dir_mode=0777 - устанавливаем права на директории
0 0 - не создавать дамп и не проверять.

Монтируем папку:

sudo mount /mnt/share

В «Линии» соответственно указываем локальный путь .

 

Share this post


Link to post
Share on other sites

Добрый день, помогите пожалуйста разобраться с проблемой.

Я прописал, все данные в fstab так, как вы сказали. 

В процессе загрузки, монтирование сетевой папки происходит, линия создает папку с данными видеонаблюдения, но создает подпапку с именем канала и даже записывает в нее данные вида .dvin. Но,  постоянная запись в папку не идет. Такое ощущение, что происходит кратковременное подключение к папке, после чего запись прекращается.

Просмотреть архив, в результате, невозможно.

Сломал уже всю голову. Прописывал разрешения на создание для системного пользователя линия, проверил и перепроверил все настройки NAS, включая разрешения на запись. 

 

Да и запись на локальный диск компьютера идет совершенно нормально.

Share this post


Link to post
Share on other sites

Здравствуйте!
В Linux «Линия»  ничего не монтирует, она  не знает, что там фактически за диск или сетевой путь, она использует  fstab.

Необходимо самостоятельно подключить  сетевой каталог по нужному протоколу и под нужным пользователем. В  «Линии» указать точку монтирования.  Никакого отношения ни пользователи «Линии» ни сама  «Линия»  к работе с сетевым каталом отношения не имеет, используйте пользователей операционной системы, которые имеют доступ к сетевому каталогу.  

Проверьте логи NAS и OS. 

Попробуйте использовать ntlmssp вместо nolock

Share this post


Link to post
Share on other sites

Извините, но почему для монтирования сетевого ресурса с NAS под линуксом используется samba, а не NFS?

Edited by kononvaler

Share this post


Link to post
Share on other sites

При монтировании по  NFS сервер с линией будет видеть сетевой ресурс как свой собственный со всеми правами и атрибутами создаваемых файлов. 

Share this post


Link to post
Share on other sites

Здравствуйте!
В Linux «Линия»  ничего не монтирует, она использует fstab.
Необходимо самостоятельно подключить  сетевой каталог по нужному протоколу и под нужным пользователем, а в «Линии» указать локальный путь (точку монтирования).  

Share this post


Link to post
Share on other sites

Также пытаюсь настроить запись на NAS. Настроил на базе OMV6. На подключенный ресурс копируется всё и читается без ошибок. Линия установлена на ubuntu server. Из под самой системы папка доступна полностью. Из других линкс систем папка доступна. Из под windows тоже. Только вот запись на ресурс не ведется. Какой волшебный аргумент нужно добавить при монтировании, чтобы линия писала или какие права нужно предоставить для программы?  

В логе

Jun 18 15:42:55 servid2 kernel[774]: [archive] failed to start day 2024-06-18 storage on /media/omv2 (usage: 0.01%, available: 491080802304, capacity: 491106512896)
Jun 18 15:42:56 servid2 kernel[774]: [db] failed to open session: SQL logic error

Share this post


Link to post
Share on other sites

Здравствуйте! 

Проверьте логи NAS 

Попробуйте использовать ntlmssp  вместо nolock

Настройки  fstab покажите. 

Share this post


Link to post
Share on other sites

/etc/fstab:

//192.168.0.15/omv2 /media/omv2 cifs credentials=/root/.smbclient,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0

mount:

//192.168.0.15/omv2 on /media/omv2 type cifs (rw,relatime,vers=3.1.1,cache=strict,username=user,uid=0,noforceuid,gid=0,noforcegid,addr=192.168.0.15,file_mode=0777,dir_mode=0777,iocharset=utf8,soft,nounix,serverino,mapposix,rsize=4194304,wsize=4194304,bsize=1048576,echo_interval=60,actimeo=1,closetimeo=1)

этого всегда хватает для работы другим програмам. Другие параметры также не работают, которые указаны ранее в посте.

 

Расшарил папку с windows, также не пишет.

mount:

//192.168.0.2/video on /media/video type cifs (rw,relatime,vers=3.1.1,cache=strict,username=user,domain=domain,uid=0,noforceuid,gid=0,noforcegid,addr=192.168.0.2,file_mode=0777,dir_mode=0777,iocharset=utf8,soft,nounix,serverino,mapposix,rsize=4194304,wsize=4194304,bsize=1048576,echo_interval=60,actimeo=1,closetimeo=1)

 

В логе ошибки:

Jun 19 17:22:32 servid2 kernel[71207]: [fs] failed to open file: /var/opt/line/settings/v2/cfg/user-data/g00000001/views, 2
Jun 19 17:22:32 servid2 kernel[71207]: [config] failed to load config data: /var/opt/line/settings/v2/cfg/user-data/g00000001/views

 

Возможно, что-то связано с правами в самой ubuntu server. Сразу после устновки ОС устанавливал все по руководству, никаких других программ на сервере нет.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×